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Инсталляция Condor Scenery Toolkit 

1. Необходимо: Запустите инсталляцию CST (Condor scenery Toolkit) для установки  
Condor Scenery Toolkit 

2. Необходимо: Скачайте и установите 3DEM GIS ПО 
 

- Скачайте 3DEM с сайта http://www.visualizationsoftware.com/3dem.html 
- Установите 3DEM 

3. Рекомендуется: Скачайте и установите Terragen программу визуализации территорий 

- Скачайте Terragen (1.6 Mb) с сайта http://www.planetside.co.uk/terragen/. Свободная 
версия ограничена, регистрация полной версии рекомендуется 

- Установите Terragen 
- Скачайте и установите плагин Sopack с сайта (набор дополнений для Terragen) 
http://www2.cs.uh.edu/~somalley/sopack.html 

4. Рекомендуется: Скачайте и установите утилиту Nvidia DDS 

- Скачайте DDS Utilities (9.4 Mb) с сайта 
http://developer.nvidia.com/object/nv_texture_tools.html 

- Установите DDS Utilities 
- Скопируйте файл nvdxt.exe из папки куда установилась программа DDS в папку куда 
установилась программа CST 

5. Рекомендуется: Скачайте и установите конвертор форматов Microsoft 3D format 
converter 

- Скачайте и установите ‘DirectX 9.0b SDK extras: Direct3D’ (1.2 Mb)  с сайта 
http://www.microsoft.com/downloads/details.aspx?familyid=EC97A1FB-4305-4758-
B7C4-5A12B3FE8EC2 

- Запустите dx90_sdk_extras_direct3d.exe и распакуйте в новую папку 

- Скопируйте файл conv3DS.exe из подкаталога ‘Old DXUtilities’ в установочную папку 
CST 

6. Рекомендуется: Установите `2D Hyperclouds plugin` для Adobe Photoshop 
- Скопируйте файл ‘2DHyperClouds.8bf’ из папки 'CST/Utilities/Photoshop plugins' в 
папку ‘Photoshop/Plug-ins/Filters’  

http://www.visualizationsoftware.com/3dem.html
http://www.planetside.co.uk/terragen/
http://www2.cs.uh.edu/~somalley/sopack.html
http://developer.nvidia.com/object/nv_texture_tools.html
http://www.microsoft.com/downloads/details.aspx?familyid=EC97A1FB-4305-4758
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Задание 1 – Скачивание и установка SRTM данных 

Шаг 1: 

Скачайте SRTM данные, котоые вам необходимы и распакуйте в необходимую папку, для 
удобства выбора территории скачайте и установите Google Earth. 

SRTM данные : ftp://e0srp01u.ecs.nasa.gov/srtm/version2/ 

Google Earth : http://earth.google.com 

Ограничение на размер сценария 400x400 кв км, рекомендуется выбрать поменьше 
размер, например сценарий Slovenia размером 230x160 кв км, это будет нормальный 
размер сценария для начала.. 

Condor не создан для больших сценариев, так как использует UTM проекцию и 
загружает данные высот за раз. 

Пытайтесь делать сценарии разумных размеров, например 300x200 кв км. 

Используйте разграфовку SRTM данных в приложении, для выбора необходимого 
сектора: 

Шаг 2: 

Запуститеt программу 3dem и разверните окно. 

Выберите File->Load Terrain Model из меню, вы увидите 8 различных типов данных, 
которые можно выбрать. 

Выберите формат SRTM Data (hgt, bil), и нажмите OK. 

Найдите ваши hgt  части, которые вы скачали и разархивировали,  чтобы выбрать 
несколько разных файлов нажмите и удерживайте кнопку CTRL, после выбора 
необходимых файлов нажмите OK. 

Я могу предложить начать с сетки 3х3. 

Например : 

N01W001, N01W002, N01W003, N02W001, N02W002, N02W003, N03W001, N03W002, 
N03W003. 

Загруженные данные будут отображены на экране. 

Замечание:    Если у вас не получается загрузить все части сценария в 3DEM, попытайтесь 
загрузить по частям, для этого загрузите 1 файл, сохраните как “USGSASCII DEM”. 
Откройте и сохраните следующий файл, пока не сохраните все файлы. В меню 
File->Load Terrain Model выберите USGS DEM. Загрузите ваши dem файлы, 
которые вы создали, держа кнопку CTRL. 

Шаг 3: 

Следующий шаг удалить ошибки в SRTM данных, для этого выберите в меню Operations-
>Patch Missing Data или нажмите кнопку F7. Теперь вы должны выбрать на какой 

ftp://e0srp01u.ecs.nasa.gov/srtm/version2/
http://earth.google.com
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территории исправлять ошибки, поместите курсор мышки снаружи в левый верхний угол, 
нажмите левую кнопку мышки, при этом появится красный квадрат, переместите курсор в 
нижний правый угол, нажмите левую кнопку мышки затем нажмите кнопку Enter. 

После обработки в маленьком окне отобразится, сколько точек было удалено, нажмите 
OK. 

Шаг 4: 

Следующий шаг преобразовать сценарий в UTM проекцию, для этого выберите в меню 
Operations->Change Projection->Convert to UTM Projection, вы увидите 4 опции: 

WGS84 
WGS72 
NAD83 
NAD27 

Выберите WGS84 и нажмите OK. 

 Шаг 5: 

Следующий шаг сохранить вашу работу, выберите в меню, 

File->Save Terrain Matrix 

Здесь будет 3 опции: 

Binary - Floating Point 
Binary - Signed Integer 
ASCII - Text String 

Выберите  Binary - Signed Integer и сохраните ландшафт в папку, с названием вашего 
сценария, в имени недолжно быть пробелов и длина не больше 16 символов. После 
сохранения появятся 2 файла. 

scenery_name.bin 

 scenery_name.hdr 
 
 
 
Шаг 6: 

Теперь вам необходимо преобразовать файл формата `bin` в файл формата `raw`, для 
этого смените расширение файла на `.raw`  (В меню Пуск выберите Выполнить… и 
запустите командную оболочку (cmd для Win2K или выше, command для win9x), затем 
перейдите в каталог, куда сохранили файлы сценария, например: 

cd “c:\condor landscape editor\” 

кавычки  “”  используются, если в названии есть пробелы 
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теперь наберите команду для преобразования формата 

`bin` в файл формата `raw` 

copy scenery_name.bin scenery_name.raw 

Закройте командную оболочку).
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Задание 2 – Преобразование в TRN файл 

Шаг 1: 

Запустите утилиту  RAW to TRN Converter, расположенную Start -> Programs -> 
Condor -> Scenery ToolKit. 

При загрузке введите ширину и высоту  сценария, эти значения можно найти в файле HDR, 
открыв его в блокноте. Для ширины поглядите значение “number_of_columns”  для 
высоты “number_of_rows” . Запишите эти значения, они понадобятся позже. 

Здесь 3 опции; Поменять колонки (Swap – width/height), развернуть по горизонтали (Flip – 
horizontal), развернуть по вертикали (Flip – Vertical). 

Нажмите кнопку “Load Raw Terrain”  и укажите `raw` файл который был преобразован из 
файла `bin` формата. 

Нажмите Open 

 Шаг 2: 

После загрузки вашего сценария в программе RAW to TRN Converter, он автоматически 
откроется в окне, выбора границ. 

В правом окне вы увидите красный квадрат, это максимальный размер, который 
RAW to TRN Converter  позволит преобразовать в TRN файл. 

Пример:  Если нижняя часть вашего сценария не влазит, то нажимая на нижний набор 
стрелок, можете обрезать нижнюю часть вашего сценария как вам необходимо, 
после этого перейдите в закладку ‘save’. 

Шаг 3: 

Нажмите кнопку Save to Condor Terrain и сохраните ваш сценарий с правильным именем 
(без пробелов и до 16 символов). Добавьте расширение TRN к концу имени файла. 

Заметьте, если вы обрезали ваш сценарий, то запишите новый размер сценария, который 
отображается в нижнем правом углу. 

Примечание переводчика: 

Размер сценария должен быть кратным 64 в направлениях север-юг и запад-восток. Программа The RAW to 
TRN converter обрежет сама ваш сценарий, если сценарий не будет удовлетворять этом условиям и вы не 
сможете точно привязаться. 
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Задание 3 – Калибровка Terrain Header 

Шаг 1: 

Запустите программу CSTLandscapeEditor . 

Примечание переводчика: 

Если вы используете старую версию .9, то программа потребует установленную версию Condor, для этого 
установите патч .12, он создаст необходимые записи в реестре, потом можно откатиться до .9 

Выберите в меню File->New Landscape и загрузите файл сценария TRN, который создали 

в Задании 2. 

Программа автоматически создаст необходимую структуру папок и файлов в директории 

\Condor\Landscapes  и скопирует файл TRN в необходимое место. 

Теперь вам необходимо определить не меньше 2 точек, желательно на противоположных 
углах территории с известными координатами в десятичном формате, dd.dddd 

Например: Для координат S47°15 – W72°35 в десятичном формате будет -47.2500 -
72.5833. Любые координаты, которые Южные и Западные отрицательные, 
Северные и Восточные положительные. 

Таблица перевода секунд в в градусы с точностью 4 знака. 
 

Секунды Градусы  Секунды Градусы 
.1 0.0167  .31 0.5167 
.2 0.0333  .32 0.5333 
.3 0.0500  .33 0.5500 
.4 0.0667  .34 0.5667 
.5 0.0833  .35 0.5833 
.6 0.1000  .36 0.6000 
.7 0.1167  .37 0.6167 
.8 0.1333  .38 0.6333 
.9 0.1500  .39 0.6500 
.10 0.1667  .40 0.6667 
.11 0.1833  .41 0.6833 
.12 0.2000  .42 0.7000 
.13 0.2167  .43 0.7167 
.14 0.2333  .44 0.7333 
.15 0.2500  .45 0.7500 
.16 0.2667  .46 0.7667 
.17 0.2833  .47 0.7833 
.18 0.3000  .48 0.8000 
.19 0.3167  .49 0.8167 
.20 0.3333  .50 0.8333 
.21 0.3500  .51 0.8500 
.22 0.3667  .52 0.8667 
.23 0.3833  .53 0.8833 
.24 0.4000  .54 0.9000 
.25 0.4167  .55 0.9167 
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.26 0.4333  .56 0.9333 

.27 0.4500  .57 0.9500 

.28 0.4667  .58 0.9667 

.29 0.4833  .59 0.9833 

.30 0.5000  .60 1.0000 
 
Расположение этих точек должно быть как можно дальше друг от друга и если возможно, 
ближе к границе сценария. Вы должны найти эти точки на карте высот, поэтому лучше 
будет, если это будут вершины холмов. Точность сценария зависит от количества точек и 
точности перевода. 

Шаг 2: 

Для поиска калибровочных точек, включите опцию Height Map (карта высот) из меню 
View/Modify List, затем используя  Zoom tool (левый щелчок приблизить, правый отдалить 
зажатая левая - перемещать) найдите вашу известную калибровочную точку (например  
известная высота). Включите опцию Calibration Option из меню View/Modify List, затем 
выберите Arrow Tool. Наведите курсор на необходимое место нажмите правую кнопку и 
выберите Add Calibration Point Here (добавить калибровочную точку). Введите широту и 
долготу в десятичном формате (dd.dddd). Повторите для остальных точек.. 

До того, как привязка будет закончена, можете заметить, что координаты будут 
показываться неправильно. После привязки, координаты должны показывать реальные 
значения широты и долготы. 

Нажмите Calibrate, затем нажмите Yes для привязки вашего TRN заголовка. 

 

Шаг 3: 

Сохраните ландшафт из меню File->Save landscape. 

После того, как ландшафт сохранён проверьте соответствие координат известных точек их 
реальным координатам. Широту и долготу можно увидеть в строке статуса, в нижнем 
левом углу. 
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Задание 4 – Проверка вашего сценария в Condor 

Шаг 1: 

Выберите  Airports из меню View/Modify List и добавьте новый аэропорт, данные по 
аэропорту можно найти на сайте www.pilotfriend.com, 

Чтобы добавить аэропорт, нажмите правой кнопкой в белом окне, слева от карты и 
выберите Add (добавить).  Введите: название, превышение, направление, длину, ширину, 
и тип покрытия. 

Замечание:    Для ввода отрицательного значения координат, введите сначала 
число, затем введите минус в начале. 

Шаг 2: 

Выберите  File->Export Flightplanner map, это преобразует ландшафт в файл формата 
bmp для Планировщика полётов, она будет выглядеть не очень, так как на данный момент 
она без текстур. Их добавим позже, но для проверки, сценарий должен быть полностью 
рабочий. 

Шаг 3: 

Выберите  File->Export forest map, это экспортирует карту лесов в формат “.for”. 

Шаг 4: 

Выберите  File->Export thermal map, это экспортирует термальную карту. 

Шаг 5: 

Выберите  File->Save landscape, это сохранит все наземные объекты в формате “.obj” 

Шаг 6: 

Выберите в меню Tools->Check for missing files, это проверит наличие всех необходимых 
файлов в вашей папке со сценарием. 

Шаг 7: 

Запустите  Condor, выберите ваш сценарий из ниспадающего меню в планировщике  
полётов, не ожидайте многого, здесь не будет текстур, объектов, деревьев, всё что 
увидите, это серую поверхность, в зависимости от настроек симулятора, сценарий может 
быть дымчатый или туманный, это нормально. 
 

http://www.pilotfriend.com
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Задание 5 – Генерация текстур с помощью Terragen 

Использование Terragen  один из способов создать текстуры для Condor. Используя 
незарегистрированную версию вы можете рендерить tiles (составные части, 
квадратики из которых состоит общее изображение сценария) только разрешением 
1280x960 пикселей, в сценарии Slovenia использованы tiles с разрешением 2048x2048 
пикселей. Для получения такого разрешения вам необходима зарегистрированная 
версия Terragen. 

Также другие программы могут быть использованы, а также фототекстуры, но для этого 
может понадобится больше ручной работы, так что Terragen не обязателен. 

Примечание переводчика: 

Для получения tiles большего разрешения, можно использовать бесплатный плагин для фотошопа 

http://developer.nvidia.com/object/photoshop_dds_plugins.html  (4.3 Мб) 

Найдите необходимый tile (в CST первые 2 цифры – Х, последние 2 – Y. t3456 àX:34 Y:56). Найти их можно 
в папке \Landscapes\Ваше название сценария\Working\textures. После обработки файла в фотошопе, 
выбираете, Сохранить как, тип файла выбираете DDS. Открывается новое окно, выбираете DXT1 (no 
alpha) и нажимаете Сохранить. После обработки сохраняете ваш tiles в папку landscape/textures, заменив 
уже существующий, если был. 

 

Шаг 1: 

Скачайте и установите Terragen с сайта www.planetside.co.uk 

Запустите программу LandscapeEditor  и выберите ваш сценарий из ниспадающего меню 
слева вверху, экспортируйте сценарий в формат Terragen выбрав  Tools->Export terrain 
to Terragen tiles. 

Шаг 2: 

Запустите программу Terragen, выберите  World File->Open World. И загрузите файл 
TerragenCondor.tgw  из папки CST/GenericFiles/Terragen. Этот файл содержит карту 
поверхности для Terragen, настройки для камеры и другие данные. По умолчанию 
настройки приведены для сценария  Slovenia и для вас могут потребоваться небольшие 
изменения настроек. 

Шаг 3: 

Нажмите кнопку  Open в окне Landscape  выберите один из  tiles который был сохранён в 
папке \Landscapes\Ваше название сценария\Working\Terragen. Вы увидите название 
tiles в статус строке в нижней части экрана. Лучше начинать работать с tiles которые 
находятся рядом с аэропортом, для проверки сценария. 

Шаг 4: 

Разрешение рендеринга и дополнительные настройки  могут быть заданы с помощью 
кнопки Render Settings, на закладке Rendering Control. По умолчанию разрешение стоит  
512x512 пикселей и максимальное разрешение в бесплатной версии Terragen 1280x960 

http://developer.nvidia.com/object/photoshop_dds_plugins.html
http://www.planetside.co.uk
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пикселей.  

Нажмите кнопку The Render Image Button в закладке Rendering control. 

После завершения работы, сохраните картинку в папку 
Landscapes\Вашсценарий\Working\Terragen, имя файла должно быть таким же, как у tile.  
(0000.bmp, 0001.bmp, ……..0814.bmp и т.д.) 

Шаг 5: 

В программе CST (Condor Scenery Toolkit Application) выберите Tools->Import Terragen 
Textures. Это преобразует размер текстур от Terragen для Condor,  вы увидите новые 
текстуры в окне для отображения ландшафта. 

Каждый раз после изменения или создания текстур, их необходимо по новой 
импортировать в CST. 

Шаг 6: 

Преобразуйте BMP текстуры в DDS текстуры используемые Кондором с помощью 
меню, Tools->Export textures to DDS. 

Проверьте новые текстуры в Кондоре. 

Рекомендуется первый раз рендерить с небольшим разрешением 512x512 пикселей, чтобы 
убедиться, что всё нормально, и только потом рендерить с нормальным разрешением. 
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Задание 6 – Генерация зон лесов 

Часть A – Основы 

Вам потребуется графический редактор, например такой, как Adobe Photoshop, который 
поддерживает формат “8bf”,  скопируйте файл 2DHyperClouds.8bf  в папку 
Photoshop/Plug-Ins/Filters  и запустите Photoshop. 

Шаг 1: 

Создайте новый документ в формате RGB bitmap (24 bit) с таким же разрешением (в 
пикселях), как и у сценария (вы записывали размер, когда делали Задание 2), после того, 
как вы создали документ, проверьте, чтобы цвет был выбран черный. 

Шаг 2: 

Выберите фильтр Filters->Render->2DHyperClouds и установите опции cloud size от 5 до 
10, levels = 6, остальные опции оставьте по умолчанию. 

Шаг 3: 

Установите контраст +100 (Image->Adjustments->Brightness/Contrast) и перемещая 
движок brightness (яркость) установите необходимую плотность хвойных деревьев, белые 
цвет – места где будут растут деревья, черный где отсутствуют. Запомните установленное 
значение яркости. 

Шаг 4: 

Выберите фильтр Filter->Blur->Gaussian  чтобы слегка размыть углы, опять установите 
контраст +100 и движок яркости, на то значение, которое запомнили. 

Шаг 5: 

Выберите в меню Image->Image Resize  и установите размер изображения в 2 раза 
больше исходного, опять установите контраст +100 и ваш уровень яркости. 

Шаг 6: 

Выберите режим оттенки серого Image->Mode->Greyscale, подтвердите flatten. Выберите 
метод 50% threshold  в меню Image->Mode->Bitmap. 

Шаг 7: 

Сохраните изображение в формате BMP в папку  
/Landscapes/ВашСценарий/ForestMaps/ConiferousMap.bmp 

Шаг 8: 

Повторите Шаги 1-6  для лиственных лесов и сохраните изображение в папку 
/Landscapes/ ВашСценарий /Working/ForestMaps/DeciduousMap.bmp 

Шаг 9: 
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Сохраните копии этих BMP картинок в другом месте, на всякий случай. 
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Часть B – Расстановка деревьев в необходимых местах 

Шаг 1: 

Скопируйте файл \Condor\Landscapes\ВашСценарий\<yourmap>.bmp   в папку 
Condor\Landscapes\ВашСценарий\Working\ForestMaps\  и переименуйте его в Map.bmp 

Шаг 2: 

Откройте его в Photoshop и измените размер картинки (в пикселях) как у файлов с 
лиственными и хвойными лесами созданными в Части А . 

Переименуйте слой содержащий изображение файла map.bmp в “Map” и сохраните 
проект фотошопа map.psd в любом месте, например на Рабочем столе. 

Шаг 3: 

Откройте файл ConiferousMap.bmp в Photoshop, выделите всё нажав кнопки CTRL+A, 
скопируйте изображение в буфер нажав CTRL+C,  откройте файл map.psd и вставьте 
скопированное изображение из буфера в новый слой нажав  CTRL+V. Переименуйте слой 
в “Coniferous” (хвойный) кликнув 2 раза на имени слоя. 

Повторите Шаг 3 для файла DeciduousMap.bmp. 

Шаг 4: 

Используя диспетчер слоёв, переместите слой “Map” наверх, перетащив его мышкой 
выше слоёв Coniferous и Deciduous, также установите прозрачность для слоя Map 
примерно 50%, установите такое значение, которое позволило бы различить все 
необходимые детали. 

Шаг 5: 

Теперь удалим лес на территории моря или больших площадей воды, если они 
отсутствуют, то игнорируйте шаги 5-6.  Выберите слой Coniferous  (хвойный) и сделайте 
его невидимым, нажав на ‘глаз’. Выбрав слой Map, перейдите в режим выбора, Select-
>Colour Range. Используя пипетку щелкните на море. Чувствительность выбора можно 
изменить движком Fuzziness slider bar. После выбора нажмите Ок. 

Шаг 6: 

Выберите слой Deciduous layer  маска выбора должна переместиться на этот слой, 
нажмите кнопку Delete и зоны морей станут прозрачными. Установите черный цвет и с 
помощью инструмента закрашивания (Paint Bucket Tool ) закрасьте черным цветом эти 
зоны.  

Используя карандаш (Pencil Tool) (кнопка “B”) сотрите все нежелательные деревья, там 
где аэропорты, города, также следует напомнить, что лиственные леса не растут высоко в 
горах или на крутых склонах, где хвойные иногда присутствуют. Замечание : Черный = Нет 
деревьев, Белый = Есть деревья. 
 
Шаг 7: 
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Используя карандаш (Pencil Tool) (кнопка “B”) сотрите все нежелательные деревья, 
например там, где аэропорт, города или открытые места. 

Повторите этот шаг для слоя хвойных деревьев (Coniferous). 

Сделайте невидимыми слоя Map и deciduous, вернитесь обратно на слой Сoniferous. 
Нажмите ctrl+A для выбора всего видимого и нажмите ctrl+C, чтобы скопировать. 

Создайте новый файл  File->New  размером как сценарий (см Задание 2) и в RGB 
формате 

Вставьте изображение из буфера обмена (нажмите ctrl+V), выберите Image->Mode-> 
Greyscale, подтвердите flatten. Выберите метод 50% threshold  в меню Image->Mode-
>Bitmap. 

Сохраните в файл BMP 
\Landscapes\ВашСценарий\Working\ForestMaps\ConiferousMap.bmp 

Повторите эти шаги для слоя лиственных деревьев и сохраните в файл  BMP 
\Landscapes\ВашСценарий\Working\ForestMaps\DeciduousMap.bmp 
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Часть C – Экспорт forest tiles в Terragen и Condor  
 
Шаг 1: 

Откройте ваш сценарий в CSTLandscapeEditor. 

Шаг 2: 

Выберите инструмент  Forest maps и отредактируйте леса рядом с аэропортами, озёрами 
и другими местами (Левый щелчок поместить деревья, правый убрать деревья) 

Шаг 3: 

Сохраните сценарий Save the Landscape, это сохранит все изменения, которые вы 
сделали в  карте лесов (forest maps) в программе CSTLandscapeEditor. 

Шаг 4: 

Экспортируйте карту лесов в Кондор с помощью File->Export forest map. 
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Часть D – Генерация текстур с помощью Terragen 

Шаг 1: 

Скопируйте файл sopack.tgp в папку, куда установили Terragen, (это плагин для 
Terragen). 

Шаг 2: 

Запустите Terragen и откройте файл TerragenCondor.tgw. 

Terragen спросит вас, как открыть bitmap, выберите Total overlay, остальные настройки 
оставьте, как есть и нажмите OK. 

Шаг 3: 

Откройте желаемый tile, например для хвойного : 
\Landscapes\ВашСценарий\Working\Terragen\ConiferousTile_XXYY и нажмите OK. 

Повторите этот шаг для Лиственного tile. 

Шаг 4: 

Щелкнув кнопку Open на закладке Landscape, откройте соответствующий  кусочек 
территории (terrain tile). 

Отрендерите как обычно, теперь на картинке леса должны быть темного цвета. Сохраните 
результат работы в Terragen. Поля будут добавлены позже, но без помощи Terragen. 

Шаг 5: 

Проверьте ваши лесные зоны в Кондоре. 
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Задание 7 – Создание полей 
В этом задании мы создадим bitmap который будет отображать карту покрытия полями, 
где белым будут отображаться поля, а черным отсутствие их, затем bitmap будет разбит 
на части (tiles) в Terragen, к которым будут применены текстуры полей с применением 
карты покрытия полей в качестве маски. Также созданную карту покрытия полей, мы  
будем использовать позже в создании термальной карты, в задании 9. 

Часть A – Создание зон покрытия полей 

Шаг 1: 

Скопируйте файл с изображением вашего сценария  

из главного каталога сценария 

\Condor\Landscapes\ВашСценарий\<yourmap>.bmp    

в папку 

 \Landscapes\ВашСценарий\Working\FieldMap 

Шаг 2: 

Откройте этот файл в Photoshop и увеличьте размер картинки (в пикселях) в 2 раза 
Image->Image Size, сохраните и закройте Photoshop. 

Шаг 3: 

Запустите Photoshop и выбрав в меню File->New создайте новый файл с размером, как у 
вашего TerrainHeightMap.raw (смотрите Задание 2). 

Шаг 4: 

Создайте примерное изображение полей с помощью фильтра, Filter->Render->2D Hyper 
Clouds. 

Шаг 5: 

Установите контраст +100 (Image->Adjustments->Brightness/Contrast) и перемещая 
движок brightness (яркость) установите необходимую плотность полей. 

Шаг 6: 

Примените фильтр Filter->Pixelate->Crystallize, чтобы поля больше походили на себя,  
установите контраст+100 (Image->Adjustments->Brightness/Contrast) и подберите. 

Шаг 7: 

Увеличьте размер картинки (в пикселях) в 2 раза Image->Image Size. 

Шаг 8: 

Выберите режим оттенки серого Image->Mode->Greyscale.  
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Шаг 9: 

Выберите метод 50% threshold  в меню Image->Mode->Bitmap. 

Сохраните файл с именем FieldMap.bmp в папку 

\Landscapes\ВашСценарий\Working\FieldMap 

Закройте Photoshop. 

Шаг 10: 

Перезапустите Photoshop. 

Загрузите ваш файл с картой в папке FieldMap из шага 1 и файл FieldMap.bmp. 

С открытым файлом FieldMap.bmp выделите всё (CTRL+A), скопируйте в буфер обмена 
(CTRL+C), затем откройте файл с изображением карты и вставьте картинку из буфера 
обмена (CTRL+V). 

Двойным щелчком переименуйте слой Background в  Map. 

Двойным щелчком переименуйте слой layer1 в  FieldMap. 

Переместите слой Map наверх и движком Opacity установите прозрачность примерно 
65% или при котором будет удобнее. 

Если в вашем сценарии отсутствуют водные объекты, то можете пропустить следующий 
шаги и перейти к 15. 

Шаг 11: 

Выбрав слой Map, перейдите в режим выбора, Select->Colour Range. Используя пипетку 
щелкните на море. Чувствительность выбора можно изменить движком Fuzziness slider 
bar. После выбора нажмите Ок. 

Шаг 12: 

Выберите слой FieldMap маска выбора должна переместиться на этот слой, нажмите 
кнопку Delete и зоны морей станут прозрачными. 

Шаг 13: 

Закрасьте прозрачные зоны черным цветом с помощью инструмента закрашивания (Paint 
Bucket Tool ) . 
 
Шаг 14: 

Скопируйте в буфер обмена слой fieldMap, создайте новый файл File->New  и вставьте 
изображение из буфера. 

Выберите режим оттенки серого Image->Mode->Greyscale, подтвердите flatten.  
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Шаг 15: 

Сохраните файл с именем FieldMap.bmp, выбрав в меню File->Save As 

Следующие опции должны быть выбраны: 

File Format – Windows 

Depth – 8 bit 

Нажмите ok. 

Удалите старый слой FieldMap, загрузите ваш новый файл FieldMap.bmp, и переместите 
его слой  вниз.  

Сотрите все зоны, где поля являются лишними. 

 Шаг 16: 

После того, как завершили редактировать, сохраните изменения в картинке, как раньше. 
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Часть B – Приписка текстур полей к Terragen tiles 

Шаг 1: 

Запустите Landscape Editor и выберите в меню, Tools->Export FieldMap to Terragen size 
Tiles. 

Шаг 2: 

Измените размер всех FieldMap tiles на размер, которым вы рендерите текстуры для 
ландшафта (обычно 2048x2048), это можно сделать с помощью конвейерной 
обработки в программе IrFanView (свободная! На сайте www.irfanview.com). 

Создайте текстуру для поля, она должна быть совместима во всех 4 направлениях, 
Размер текстур используемый в Кондоре 256x256 пикселей, это зависит от размера 
ваших полей.. 

Скопируйте вашу текстуру поля в папку 

\Landscapes\ВашСценарий\Working\FieldMap 

Шаг 3: 

Запустите и загрузите в Photoshop вашу текстуру поля, выделите всё (кнопки ctrl+A) и 
задайте образец выбрав в меню, Edit->Define Pattern, нажмите ctrl+D чтобы снять 
выделение, после этого можете закрыть её. 

Откройте одну из ваших Terragen tiles, которую вы отрендерили. 

Шаг 4: 

Создайте новый слой выбрав в меню, Layer->New->Layer или нажав кнопки 
SHIFT+CTRL+N, оставаясь на этом слое, выберите инструмент заливки из меню, Edit-
>Fill, в ниспадающем меню Contents->Use выберите Use->Pattern и выберите вашу 
текстуру поля, нажмите ок. 

Теперь на экране должна отображаться только ваша текстура. 

Шаг 5: 

Откройте FieldMap tiles с таким же именем, как у вашей Terragen tile. 

Шаг 6: 

Инвертируйте изображение, выбрав в меню, Image->Adjust->Invert или нажав кнопки 
CTRL+I, выделите всё, скопируйте и вставьте новым слоем на вашей Terragen tiles. 
 
Шаг 7: 

Вы можете переименовать каждый слой, для большего удобства, но это не обязательно. 
Выберите инструмент, волшебная палочка (Magic tool), и выберите все белые зоны на 
вашем FieldMap слое, удерживая кнопку shift чтобы выбрать несколько зон, после того, 
как все зоны были выбраны, выберите в меню, Select->Feather или нажмите кнопки 

http://www.irfanview.com
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ALT+CTRL+D, введите значение от 10 до 15 и нажмите ок. 

Шаг 8: 

Сделайте невидимыми слой FieldMap tiles, нажав на глаз рядом с ним, выберите слой с 
текстурой Field texture . 

Шаг 9: 

Добавьте маску Layer->Add Layer Mask->Hide Selection, измените прозрачность слоя, 
какая требуется (примерно 65%). 

Объедините слои Layer->Flatten Image,  выбрав слой FiledMap texture, когда появится 
сообщение  ”Исключить скрытые слои? ” (“Discard hidden layers?”), нажмите ок. 

Шаг 10: 

Сохраните файл, выбрав в меню, File->Save As и замените существующий файл, 
установите опции для BMP файла: 

File Formats – Windows 
Depth – 24 bit Click ok. 

Повторите для остальных ваших Terragen tiles в вашем сценарии. 
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Задание 8 – Создание Термальной Карты 

В этом задании мы создадим карту вероятностей/силы термиков на основании 
солнечной освещённости, карт полей и лесов. 

Конечный результат изображения должен быть в RGB формате, но только красный канал 
при этом используется, поэтому лучше работать с оттенками серого, светлые участки 
отображает зоны хорошей термальной активности, темные плохой. 

Лучшие участки должны быть – это солнечные откосы (100%), потом поля (70%), трава и 
хвойные деревья (40%) и лиственные деревья и затемнённости (25%). 

Шаг 1: 

Откройте в программе Landscape Editor  ваш сценарий, затем выберите в меню, 

 Tools->Export terrain to RAW format, после завершения операции выйдите из программы. 

Файл  TerrainHeightMap.raw будет сохранён в следующей папке. 

Condor\Landscapes\yourlandscape\Working\Terragen. 

Запишите на бумажку размеры по высоте и ширине, это понадобится в следующем шаге. 

Шаг 2: 

Откройте в программе Photoshop файл TerrainHeightMap.raw, и в соответствующих полях 
введите ширину и высоту картинку из шага 1,  RAW файл будет открыт как  16 bit IBM PC, 
теперь его необходимо преобразовать в формат 8 bit\channel RGB выбрав в меню. 

Image->Mode->RGB Color 
Image->Mode->8 bits/channel 

Шаг 3: 

Создайте новый слой, как копию основного слоя (background layer), вы можете 
переименовать каждый слой, для большего удобства, но это не обязательно. 

Примечание переводчика: 

Layer->New->Layer From Background 

Layer->New->Layer Via Copy 

 

Шаг 4: 

Инвертируйте слой background layer  и установите для него контраст (contrast) +100, 
яркость (brightness) +20  и нажмите Ок. 

Примечание переводчика: 

Image->Adjustments->Invert 
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Image->Adjustments->Brightness/Contrast 

Шаг 5: 

Выберите слой 1 (layer 1) созданный в шаге 3, затем установите следующие параметры 
для  Lighting Effects в меню Filter->Render->Lighting Effects. 

Light Type : Directional 

Intensity : Full 
Значение должно быть +100 

Gloss : Matte 
Значение должно быть -100 

Material : Plastic 

Значение должно быть -100 

Exposure : 0 

Ambience : 0 

Texture Channel : Red 

White is High : выбрано 

Height : Mountainous 
Значение должно быть +100 

Свет должен распространяться с юга, длина световой линии должна быть ¾ высоты 
изображения на картинке предварительного просмотра (preview image) (а также 
расширяться за размеры окна на ¼ длины окна) нажмите ok. 

Шаг 6: 

Для слоя 1 (layer 1) установите контраст (contrast) +100, яркость (brightness) -40, нажмите  
ok. 

Примечание переводчика: 

Image->Adjustments->Brightness/Contrast 

 

Шаг 7: 

Выберите режим “Lighten” для слоя 1 (Layer1) кликнув 2 раза на изображение слоя в окне 
диспетчера слоёв в блоке General Blender. 

Шаг 8: 

Слой 1 должен быть теперь выровнен, выбрав в меню, Layer->Flatten Image. 

Шаг 9: 
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Откройте вашу Лиственную карту (DeciduousMap) и уменьшите размер картинки на 50%, 
затем добавьте эту картинку к исходному слою (original background layer), инвертируйте 
изображение и установите яркость +100. 
 
Шаг 10: 

Выберите режим “ multiply ” для слоя 1 (Layer1) кликнув 2 раза на изображение слоя в окне 
диспетчера слоёв в блоке General Blender. 

Шаг 11: 

Слой 1 должен быть теперь выровнен, выбрав в меню, Layer->Flatten Image. 

Шаг 12: 

Откройте ваш FieldMap и уменьшите размер картинки на 50%, затем добавьте эту 
картинку к исходному слою (original background layer), инвертируйте изображение и 
установите яркость -50. 

Шаг 13: 

Выберите режим “Lighten” для слоя 1 (Layer1) кликнув 2 раза на изображение слоя в окне 
диспетчера слоёв в блоке General Blender. 

Шаг 14: 

Слой 1 должен быть теперь выровнен, выбрав в меню, Layer->Flatten Image. 

Шаг 15: 

Сохраните файл, Working\ThermalMap.bmp 

В опциях выберите 24 bit. 

Шаг 16: 

Откройте программу Landscape Editor и откройте ваш сценарий, выберите Thermal Map в 
меню и проверьте, что битмап загрузился правильно. 

Шаг 17: 

Выберите в меню File->Export ThermalMap, чтобы экспортировать данные в файл 
LandscapeName.tdm, который используется Condor для описания термиков. 

Шаг 18: 

Проверьте в Condor потоки, полетав над разными местами. 
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Дополнительная информация 

Дополнительная информация может быть найдена на форуме Condor Scenery: 

 http://forum.condorsoaring.com 

http://forum.condorsoaring.com
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Кому спасибо 

Мы должны сказать спасибо нашей команде бета тестеров за их поддержку и 
комментарии. 

Отдельное спасибо: 
 
Geoff McVey (ASH33M) за этот документ 
George Winnard (Desktopsimmer)  
Wolfgang Hake (Mosquito) 

Sau за перевод.
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Приложение  

Карта STRM данных 


